.
SynchroArts.com works best with JavaScript enabled

Make sure that you are using VocALign Project 3.0.1 AU or later which fixes an alignment problem with Logic 9. The latest version can be downloaded from Downloads