.

FAQ

SynchroArts.com works best with JavaScript enabled

Please make sure you have installed VocALign Ultra 1.0.12.1 or later, this includes a fix for the problem.