User Guide Index

Importing and Exporting Audio

This chapter describes:

TIP: Check www.synchroarts.com regularly for updates on workflows with specific DAWs.


Revoice Pro Audio Format Requirements

Input Audio Requirements and Output Formats

WARNING: You cannot use waveforms with different bit depths and/or different sampling rates in the same Revoice Pro Session.

Each Revoice Pro Session's Sampling Rate and Resolution (Bit Length) are set and fixed automatically to the settings of the first audio signal imported into the session. After that, Revoice Pro will offer to resample any non-matching audio file that is imported, to match that Session's Sampling Rate and Resolution.

 

Note for Windows users

The menus shown in this chapter are captured from the Mac OS version of Revoice Pro. However, the contents of these menus will be substantially the same for the Windows OS version (apart from file system operational differences). Any other major differences will be noted.

 

Back to Index

Audio Transfer between Revoice Pro and DAWs

Because Revoice Pro is a stand-alone program, we know that a critical part of your workflow is getting audio out of and back to your Digital Audio Workstation (DAW) as quickly and as easily as possible. We have tried to make the workflow with Revoice Pro meet this criteria.

The Basic Workflow steps are simply:

The audio transfer methods are summarised in two tables below and work with most brands of DAWs including Pro Tools, Logic Pro, Ableton, Cubase, Nuendo, Reaper, etc. Which method(s) you chose for transferring audio will depend both on your DAW, the methods it supports, and the amount of audio you want to transfer.

This chapter, although lengthy, has been organised so you should be able to follow the links below to skip to the sections related to the DAW, plug-in type, or specific operation you are interested in.

Also, note, starting with Revoice Pro 2.5, besides the basic descriptions below, there are also some new DAW-specific manual chapters for describing special high-speed workflows for some DAWs.

The table below - provides a Summary of the main methods, advantages, and links to sections in the manual describing these.

How to transfer audio
from your DAW to Revoice Pro

Method Advantages/Comments

Revoice Pro Link Plug-ins

  • Audio Suite and AAX - one or more regions from one track instantly
  • AU, VST3 - multiple tracks simultaneously - real time

"Quick" APT Plug-in
and
"Quick" Doubler Plug-in

Audio Suite and AAX

  • For Pro Tools only
  • High-speed, simplified workflow - captures, processes and returns audio to Pro Tools (like VocALign).
  • 3-track session only
  • Limited session tools available

Copy in DAW and Paste into Revoice Pro

or
Drag from DAW and Drop
into Revoice Pro

  • Works with Nuendo 5 (and up) and Cubase 5 (and up).
    [NEW starting with Revoice Pro 2.6]
  • Works with Logic Pro
  • Faster than real-time
  • Transfer mulitple regions
  • Uses Timecode (if present).
  • Maintains region names
  • Does not duplicate audio

Drag and Drop audio files into Revoice Pro.

Files can be existing .wav or .aiff, bounced or Exported from DAW to disk.

  • Faster than real-time
  • Transfer multiple tracks and regions simultaneously
  • Uses Timecode (if present).
  • Uses file names
 

How to Transfer Processed Audio
from Revoice Pro to your DAW

Method Advantages/Comments

Drag and Drop directly into DAW track

  • Instantaneous
  • One processed region at a time
  • Spot to timecode (might require extra DAW command)
  • Normally keeps name of region

Export audio to files and drag files into DAW

  • Multiple tracks, multiple regions simultaneously.
  • Spot to timecode.
  • Automatic creation of file names from user-specified elements.

Audio Suite and AAX Plug-ins
Revoice Pro Link and Quick APT and Doubler
(for Pro Tools only)

  • One or more region from one track spotted instantly to timecode in DAW

 

Back to Index

Workflow Step 1: Transfer audio from DAW to Revoice Pro

As shown in the chart above, there are several methods for getting audio from your Digital Audio Workstation (DAW) into a Revoice Pro session. In the chart below, we identify some of the DAWs that are known to work with each method. The links take you to procedures both in this chapter or to a DAW-specific chapter in the case of newer functions.

Transfer Method

DAWs (confirmed)

Drag and drop one or more audio files into Revoice Pro.

Files can be already available, or created by bouncing or Exporting from DAW to disk.

Most DAWs.

DAW Region Drag and Drop

DAW Region Copy and Paste

Cubase, Nuendo

Revoice Pro Link plug-ins

"Quick" APT & "Quick" Doubler

Pro Tools only

 

The steps for each method are described below.

Method 1. Drag and Drop one or more audio files

This is a very efficient and fast method if the audio already exists in files.

Alternatively, an approach which is less efficient than the other methods is for the user to generate multiple named files from the DAW- e.g. one for each track of audio to be processed. In this approach, the first step must be to get the audio from the DAW into Revoice Pro by either Exporting or "bouncing" the audio to be processed from the DAW to one or more audio files. These can be mono, stereo or multichannel (generally less useful) files. Once exported, the user simply selects and drags one or more audio files from the Mac or Windows file system and drops them into any Revoice Pro session track(s).

TIP: If using this method, we recommend using the BWF (Broadcast Wave File format) because these files contain correct timecode information. If BWF format is not available, use .wav format.

Below we show an example of dragging and dropping two files into Revoice Pro.

Ready to drag two selected files into Track 1 waveform areaDrag Audio Files

After "drop", files with timecode will appear at the correct timecode.
Plus, each track is auto named from first dragged filename

After Drag and drop

Using start timecodes in the Audio Files

If the user knows that the audio files being dragged into Revoice Pro have valid and useful timecode stamps, then the Revoice Pro Auto Spot switch can be enabled to use those timecodes without requiring the user to confirm the use of the timecode.

  1. To enable Auto Spot, click Tracks in the Revoice Pro menu bar, and select Auto Spot as shown left.
  2. When this window is opened again, Auto Spot will be selected as shown right.
  3. To disable Auto Spot, click Auto Spot again.

Auto Spot selection

 

Main rules for Drag and Drop audio files

Back to Index

 

Method 2. Transfer to Revoice Pro via a Revoice Pro Link Plug-in

Revoice Pro Link Switch

Revoice Pro Link SwitchTo transfer audio using any of the Link Plug-ins to Revoice Pro, the Revoice Pro Link Switch must be ON (green as shown left) in the destination Revoice Pro Session window.

Otherwise, the Link plug-ins will display an error message.

Only one Revoice Pro Session can have this switch ON at a time.

As explained previously, there are mutliple Revoice Pro Link Plug-ins with individual details available by clicking the plug-in name below:

Operation of the LINK plug-ins with other DAWs using the above plug-in standards is often possible, but depends on the full standard of the plug-in standard being implemented by the DAW manufacture. However, Revoice Link plug-in operation with other DAWs can easily and quickly be tested by the user.

Back to Index

Audio Suite and AAX Plug-ins Link (for Pro Tools)

Revoice Pro LinkThe Revoice Pro Link Audio Suite plug-in for Pro Tools is shown at the right. The AAX Plug-in is identical in structure and operations.

These plug-ins reside in the Pro Tools Audio Suite plug-ins "Other" folder and must be selected and running in Pro Tools to appear and operate.

At the top of the plug-in window in the Audio Suite (and AAX) "Header" are the standard Audio Suite controls. These settings will be discussed in this section last. (Detailed information about header controls is available in the Pro Tools Help system.)

The black panel below the header contains mainly instructions and a destination Track selector switch.

In the Audio Suite "Footer" controls at the bottom, the Capture button starts the copying of audio selected in Pro Tools to Revoice Pro.

Note also, this is the only Link plug-in version that can transfer audio back from Revoice Pro to a DAW (Pro Tools) apart from the new "Quick" APT and Doubler plug-ins described here.

The Spot button sends the processed audio from Revoice Pro back to the user-selected tracks and correct timecode in Pro Tools. This action is described here.

 

Preparation before transferring audio from Pro Tools

Before using the Audio Suite or AAX Link plug-in, make sure in Pro Tools that the Session Setup window shown below (found in the Pro Tools Setup menu under Session) is set either to 0:0:0:0 or to a desired timecode offset (a 1 hour offset is shown in the example).

Pro Tools Session Offset

This Pro Tools Session Start offset will be added to the captured audio start timecode and be used as the timecode start in Revoice Pro.

NOTE: If using Rewire for auditioning from Revoice Pro, the same offset must be set in Revoice Pro's Settings window in the Revoice Pro View menu. Click here for more details.

Transferring mono waveforms from Pro Tools to Revoice Pro

The section headed Pro Tools --> Revoice Pro is used to instantly transfer selected audio from a Pro Tools track to a Revoice Pro track.

Before making any transfers, once the Revoice Pro plug-in is visible, decide whether you want the individual audio regions in Pro Tools to be kept as individual regions in Revoice Pro or made into a continuous file. The Audio Suite header switches shown circled in red below will control this and will be explained further below.

AS Link Header

The transfer operation itself is simple.

  1. In Pro Tools, select the region(s) of audio that you want to transfer.
    In the example shown below, two audio regions and the silence between them are selected in a Pro Tools track.

The next two instructions written in the plug-in are largely self explanatory.

  1. Select the destination Revoice Pro Track using the drop down selector button after "1) Revoice Pro Track".
    The window that appears will show the names of all the available Revoice Pro Tracks as they are labelled.
    In the example below - the track in Revoice Pro labelled "Audio 4" is selected as the destination track for the audio.

  1. Press the Capture button in the Plug-in "Footer" AS Link Capture
    The selected audio will be immediately captured and transferred from Pro Tools to Revoice Pro.

 

Audio Suite and AAX Header Settings for Transfer

Using the example selected two waveform region os shown above, the settings in the Link's Audio Suite and AAX header will change the way that multiple audio regions are loaded into Revoice Pro - as shown below. (Other settings should not be used with multiple regions.). The "clip-by-clip" setting will maintain separated regions and create "silent" regions between waveform blocks.

Audio Suite and AAX Header Result in Revoice Pro
AS Link Contin Clip by Clip AS Link Contin Clip by Clip Waveform

AS Link Contin Entire Selection
(Above is recommended) or

AS Link - Create Individ Ent Select

AS Link Create Indiv - Entire Select Waveform

 

Multitrack Selection and Transfer

The Pro Tools selected input can be across multiple tracks and in the example below, we have captured two regions in each of two tracks along with the silence between.

AS Link - Two channel Pro Tools source

When the capture is made with either of the header settings shown below, if "multi-input mode" is selected the Pro Tools tracks are combined into a stereo waveform as shown below to the right. Again, if "clip-by-clip" is used instead of "entire selection", the results will be split into multiple regions as above for the mono signal example.

Audio Suite and AAX Header Result in Revoice Pro

AS Link - 2 in Contin Entire Mutlior

AS Link 2 In - Create Individ Entire Multi

AS Link 2 In - Contin  Entire Multi Wave

 

This ends the discussion on the Audio Suite and AAX Link plug-in transfer from Pro Tools to Revoice Pro. You can now:

Back to Index

 

Audio Units (AU) Plug-in Link (for Logic Pro, etc.)

In this section, we will show how to transfer audio from Logic Pro to Revoice Pro, using the Revoice Pro Link AU plug-in.

Note: These techniques should also work with other DAWs that use AU plug-ins such as Ableton Live, etc. but check by trying it first. Or check on www.SynchroArts.com for a compatibility chart.

TIP: It is important to understand that a Link plug-in can be inserted into each track, and there is no limit to how many Link plug-ins can be inserted in the DAW. This means one or more tracks can be transferred at the same time. Transferring more tracks at the same time can greatly speed up your workflow.

Alternative (faster) Export and drag method for Logic Pro Regions

Because of the way AU plug-ins work, the Link transfer operates like a "real-time" bounce to disk and therefore will take as long as the selected audio plays. This might be efficient, if transferring several tracks to Revoice Pro at the same time.

An alternative to consider (particularly with longer files) is using a faster-than-real-time export or "bounce" of audio files containing the desired tracks, and then dragging these files into Revoice Pro, as described previously here.

For Logic Pro, to export a single Region, the Logic File menu item

File -> Export -> Region as Audio File...

will create a named audio file from the selected region that can be dragged into a track in Revoice Pro.

This may be much faster than using the Link plug-in and the exported file name will become the Revoice Pro Region name .

 

Preparation before using AU Link plug-ins for transfers to Revoice Pro

  1. Revoice Pro Link SwitchMake sure the Link switch is ON (as shown right) in the Revoice Pro Session window where you want to receive the audio, because this tells the Link plug-ins where to send it.
  2. We recommend that you name the Revoice Pro Session tracks to names that will identify the audio received in each track.
    (In our example below, we've left the Revoice Pro Tracks named Audio 1, Audio 2 and Audio 3.)
  3. AU SMPTE settingMake sure you check in the Revoice Pro View, Settings window (shown right), that Revoice Pro's DAW Timecode Offset / SMPTE Time is set to the same Offset as the Logic Pro Project Synchronization setting. Logic normally sets this by default to 1 hour, as we also do in Revoice Pro. The Time display will show the actual corresponding running time - based on the Timecode Rate.
  4. The DAW setting does not affect performance with AU plug-ins.

The main steps to use the AU Revoice Pro Link plug-in:

  1. In Logic Pro, insert the Revoice Pro Link plug ins as an Insert on each track you want to transfer audio from. Access the Link plug-in from the Audio menu as shown below.

Link AU Insert Menu

  1. Once the Revoice Pro Link plug-in is set as an Insert in Logic Pro, it will be shown as below and be labelled with the name of the Logic Pro Track, which in this example is called "Guides".

Link AU Guide

In the picture above, the AU Plug-in header is presented. However, clicking the top right hand button will remove the header and make the Plug-in more compact, as shown below showing only the essential controls.

AU Link in compact format

  1. The Revoice Pro destination track is selected in each Link plug-in by clicking the drop down bar, which will reveal a list of the track names in Revoice Pro. Select the required track. In the example above and below, "Audio 1" is selected.

VST3 Link - Track Select

  1. Repeat the insertion steps (1 and 2) and Destination track selection step (3) for every Logic Pro track that contains audio to transfer.
  2. VST3 Link - Guide SelectClick on the Capture Enable switch under the label "Capture" to make it turn ON (shown in green at right).
  3. ALL Capture switches in visible Link modules can be toggled ON or OFF by holding down the SHIFT key and clicking any of the modules' Capture Enable switches. Below we show two Link modules with Capture enabled.

VST3 Link - Three modules

  1. Line up the Logic Pro Playhead to the start of the audio you wish to transfer and start the Logic Pro playback. All of the tracks that have the Capture enabled will begin transferring the captured audio to Revoice Pro tracks.
  2. An elapsed time indicator will show a running total of the duration of the audio captured as shown below.

VST3 Link - Capturing

  1. When all of the audio to be captured has been played, stop the Logic Pro playback. The capture operation will stop and the captured audio will appear in the selected tracks in Revoice Pro.

Further information on Link modules.

  1. When capture stops, all the Capture switches will automatically toggle off so you don't accidentally start a capture again.
    But, if you do, Revoice Pro will show overlapping audio via a Warning indicator at the right of the screen and a yellow line under the area of overlapping audio.
  2. Lastly, the area under the Link's Track selector is where any Error Messages will appear (in Red), such as below, which occurs when you don't have any Revoice Pro Session window's Link switch On.

Link AU - no capture on

This ends the discussion on the AU Link plug-in transfer with Logic Pro (and similar DAWS using AU plug-ins) to Revoice Pro.

You would next Process the captured audio.

 

VST3 Link Plug-in (for Cubase, Nuendo, etc.)

In this section, we will show how easy it is to transfer audio from Cubase to Revoice Pro, using the Revoice Pro Link VST3 plug-in.

Note: These techniques should also work with other DAWs that use VST3 plug-ins such as Nuendo, Reaper, etc. but check by trying it first. Or check on www.SynchroArts.com for a compatibility chart.

 

IMPORTANT UPDATES: If using Nuendo or Cubase versions 5 and up, we recommend using the newest Copy and Paste or Drag and Drop operations described in this Manul here and also regularly updated on our website here.

 

ALTERNATIVE: Because of the way VST3 plug-ins work, this transfer operates like a "real-time" bounce to disk and therefore will take as long as the selected audio plays. This might be efficient, if transferring several tracks to Revoice Pro at the same time. An alternative to consider is using a faster-than-real-time bounce to disk audio files of the desired tracks, and then dragging these files into Revoice Pro, as described previously here.

TIP: It is important to understand that a Link plug-in can be inserted into each track, and there is no limit to how many Link plug-ins can be inserted in the DAW. This means one or more tracks can be transferred at the same time. Transferring more tracks at the same time can greatly speed up your workflow.

 

Preparation before making audio transfers to Revoice Pro

  1. Revoice Pro Link SwitchMake sure the Link switch is ON (as shown right) in the Revoice Pro Session window where you want to receive the audio, because this tells the Link plug-ins where to send it.
  2. We recommend that you Name the Revoice Pro Session tracks to names that will identify the audio received in each track.
    (In our example below, we've left the Revoice Pro Tracks named Audio 1, Audio 2 and Audio 3.)

The main steps to use the VST3 Revoice Pro Link plug-ins are:

  1. In Cubase, insert the Revoice Pro Link plug ins as an Insert on each track you want to transfer audio from. Access the Link plug-in from the Audio menu as shown below.

Cubase Insert Plug in menu

  1. Once the Link plug-in is set as an Insert, it will be shown as below and take on the name of the Cubase Track. In the example, it is called "Guide Voice".

VST3 Link - Inserted

  1. The Revoice Pro destination track is selected in each Link plug-in by clicking the drop down bar which will reveal a list of the track names in Revoice Pro. Select the required track. In the example below, "Audio 1" is selected.

VST3 Link - Track Select

  1. Repeat the insertion steps (1 and 2) and Destination track select steps (3) for every Cubase track that has audio to transfer.
  2. VST3 Link - Guide SelectClick on the Capture Enable switch under the label "Capture" to make it turn ON (shown in green at right).
  3. ALL visible Link modules can be toggled ON or OFF by holding down the SHIFT key and clicking any of the modules Capture Enable switches. Below we show three Link modules all with Capture enabled.

VST3 Link - Three modules

  1. Line up the Cubase Playhead to the start of the audio you wish to transfer and start the Cubase playback. All of the tracks that have the Capture enabled will begin transferring the captured audio to Revoice Pro tracks.
  2. An elapsed time indicator will show a running total of the duration of the audio captured as shown below.

VST3 Link - Capturing

  1. When all of the audio to be captured has played, stop the Cubase playback, the capture operation will stop and the captured audio will appear in the selected tracks in Revoice Pro.

Further information on Link modules.

  1. All the Capture switches will automatically toggle off so you don't accidentally start a capture again.
    But, if you do, Revoice Pro will show overlapping audio via a Warning indicator at the right of the screen and a yellow line under the area of overlapping audio.
  2. Lastly, the area under the Link's Track selector is where any Error Messages will appear (in Red), such as when you don't have any Revoice Pro Session window's Link switch On.

This ends the discussion on the VST3 Link plug-in transfer from Cubase (and similar DAWS using VST3 plug-ins) to Revoice Pro.

You would next Process the audio.

Back to Index

Workflow Step 2: Do the Processing in Revoice Pro

Once the audio is loaded in Revoice Pro, the waveforms can be processed (with APT or Doubler processes) and/or Edited. In Revoice Pro, you will normally send the processed audio into Output Tracks.

  1. You will often need to create these output tracks and we recommend that you name these tracks with “Out” (or something similar) in the name. (e.g. "Out-Lead 1" or "Out-Actor 1"
  2. Do your Revoice Pro processing into these Output tracks.
  3. You then will need to get the transfer the Processed Output audio back to your DAW.

This is described in the next workflow section.

Back to Index

 

Workflow Step 3: Transfer audio from Revoice Pro to DAWs

There are three simple methods for getting audio out of the selected Revoice Pro Session window and back to your DAW.

  1. Drag and Drop individual processed regions from Revoice Pro directly into your DAW tracks.

  2. Export one or more tracks of processed Revoice Pro Audio to files and drag these into your DAW.

  3. If using Pro Tools, you can use the Revoice Pro Link Audio Suite plug-in or the "Quick" APT and Doubler plug-ins described here.

 

NOTE: After using method 1 and 2, you will probably need to use a DAW command to shift the audio to the right start time.

Instructions for each of these methods follows.

1. Drag a Waveform region from Revoice Pro and drop it into your DAW

This approach is intuitive, quick and will probably work with most DAWs.

  1. Select Revoice Pro's window with the processed audio.
  2. Hold down the SHIFT and ALT (Mac) / SHIFT and Ctrl (Windows) keys on the keyboard.
    (Do not press the mouse first or you might move the waveform.)
  3. Drag Processed AudioLEFT CLICK on the processed waveform and keep holding down the LEFT mouse key.
    The white (.wav) document symbol shown at the right should appear.
  4. You should now release the keyboard keys (for compatibility with some DAWs).
  5. Keeping the LEFT mouse button held down, drag the document icon into a track in your DAW. Release the LEFT mouse button.
    The waveform will go to a position near where you "dropped" it, but not necessarily to the correct start timecode. If that's the case, the next step will move it to the correct start timecode.
  6. Use your DAW's "Spot", "Move to Original Timecode" or equivalent function to snap the dragged audio to the correct timecode.
    We list examples of the specific command below for a few DAWs.

Table of "Spot" Commands to move audio to correct Start

DAW Command Notes
Cubase / Nuendo

After dragging in audio to DAW track, select the Cubase Edit menu that shows "Move to", and select "Origin” option.

You can also set and use a quick key command.

For example:
Set keys to
ALT SHIFT O.

Logic

Select the menu that shows “Move to Recording Position”  (or “Move Region to Original Recording Position”) and click that option. 

You can also use the corresponding key command, default assignment:  
SHIFT-CMD-R
Pro Tools

RIGHT CLICK dragged audio and chose "Spot" from pop-up menu. This will bring up the "Spot Dialog" box.

Click the "Original Time Stamp" selector and press OK.
(See pictures below)

Set "Auto-Spot" (if available) in Options menu.
Other Editors Look for similar commands to "Spot" or "move audio start to timecode stamp".  

 

Back to Index

 

Illustrated Example: "Spotting" audio dragged from Revoice Pro in Pro Tools to correct timecode

Drop audio in Pro Tools

a) Processed audio from Revoice Pro is dragged into Pro Tools track in bottom track

 

Spot menu

b) Pro Tools Spot function is selected

Drag Drop Spot 2

c) In Pro Tools "Spot Dialog" window, select "Use Subframes", if available.

d) Select "Original Time Stamp" Dialog and click OK

Drop and Spotted in Pro Tools e) Processed audio snaps to correct position.

 

Back to Index

2. Export Selected Tracks from Revoice Pro as files and Drag files into DAWs

This method is another approach to Step 3 in the Example Workflow and provides extremely fast and efficient transfers of all or selected portions of Revoice Pro's Processed audio tracks.

When ready to export audio from Revoice Pro, select the File menu in Revoice Pro and select Export Audio as shown in the Mac menu (left) or Windows menu (right). Alternatively use CMD E (Mac) / Ctrl E (Windows).

Export Audio File MenuFile Menu Windows

Either the small or extended version of the Export Audio As... window will appear with the small version shown directly below. Clicking the control indicated by the red arrow will switch the view from the small to the extend version shown in the next picture, and vice versa.

Export Audio Menu

The extended version of the Export Audio window shown below allows more options for finding folders and devices and displaying file information.

Export Audio window extended

For the rest of this example, we will show how to export a selection of tracks from the Revoice Pro Session shown below where the last 8 tracks of the session are visible.

Export audio - RV Shine Session

Export Audio Default WindowWith the above session, when Export Audio is selected, the (small) Export Audio As ... window similar to that shown right will appear.

Note that no tracks or options are selected yet.

The destination folder is shown as "Shine Session". This can be changed as appropriate.

We will next look at track selection and the auto file naming system.

In the picture below, we have selected tracks 8,9,10 and 12.

Export Track selection

Note that the names of the Files that will be created are shown in the "File Name" column. These have been automatically named by combining the Track Name and the default Save As: prefix name "Audio".

In addition, the number of channels contained in each file is shown.

We can make the name of the file more relevant by changing the "Prefix" name in the Save As window. In this case, we have changed it to "Shine" and the Files names are automatically changed to include this prefix as well.Export Audio name change

Note that the option "Export Selected Playback Area" is NOT checked, so all of the audio in the selected tracks will be exported. The time range of export is shown following the "Export Starting at ...." message.

 

Using a Playback Range to define audio export range

If we select the option Export Selected Playback Area, as shown below, we can see that the time range being output is now modified to only include the audio within the Playback Range (defined by the yellow bar at the top of the Session).

Lastly, if we select the option "Save selected tracks as a [N] channel file", where N will be the total of the number of channels in all the selected files and one file will be saved. In the example below - there are 4 mono tracks, so a 4 Channel file will be saved. If there were 4 stereo tracks, an 8 channel file would be saved.

Note that not all DAWs would be able to use such multi-channel files.

 

Saving the files

When all the options and file names are set as required, click SAVE. The named audio files will be saved into the directory shown in the "Where" window.

Importing the files into your DAW

This completes the operation for Exporting audio in multiple selected tracks from Revoice Pro to your DAW.

Back to Index

 

3. Transfer audio from Revoice Pro to Pro Tools using Revoice Pro Link Audio Suite or AAX Plug-in (Pro Tools only)

Link AS PanelThe Revoice Pro Link Audio Suite (shown right), can instantly transfer and "Spot" a single audio region from Revoice Pro to the correct timecode in a designated Pro Tools track.

NOTE: The AAX version operation and appearance is identical.

This is an extremely quick method for transferring processed regions individually.

This plug-in resides in the Pro Tools Audio Suite plug-ins "Other" folder and must be selected and running in Pro Tools to appear and operate.

Revoice Pro Link SwitchIn order for transfers to take place, the Revoice Pro Link (Audio Suite) plug-in must be running in Pro Tools and the Revoice Link switch in Revoice Pro must be ON (green) in the source Revoice Pro session's window (as shown right).

TIP: We recommend that the Pro Tools Audio Suite or AAX Header controls (at the top of the Link plug-in window) should be set mainly according to the image below.

Audio Suite Link Header

There are only some variations of these switches that will work correctly:

The lower section of the Link plug-in shown above, in the section displaying Revoice Pro -> Pro Tools, provides the three simple steps which we explain further below.

1) In Revoice Pro, select the audio you wish to transfer.

NOTE: Audio may already be selected automatically after processing - so you often do not need to do this step.

Link AS before Spot2) In Pro Tools, select the destination by highlighting an area in the target track.
(See the image at right.)

The red arrows show where a range in track "Audio 3" has been marked to select that track (but not the start time).

3) Press the Spot button (shown right)Link AS Spot button

Link AS after SpotThe selected audio in Revoice Pro will be transferred to the selected track at the correct timecode start in Pro Tools as shown right in Track Audio 3.

If a Pro Tools track is selected in the Link's header, then the audio will be placed there.

 

TIP: If the timecode position of the audio spotted in Pro Tools is wrong, make sure the Sample Rate settings for the Pro Tools Session and the Revoice Pro Session are the same.

Back to Index

Notes on Bouncing Audio from DAWs

Workflow and settings for three popular DAWs

are given below, but the issues raised will apply to all DAWs.

Pro Tools (V10)

  1. In Pro Tools, Select File, Bounce To, Disk...
  2. A Bounce setup window will appear similar to that shown below.

Pro Tools Bounce menu

  1. Make sure the File Type is set to WAV.
  2. If the Revoice Pro Session already contains audio, make sure that Bit Depth and Sample Rates are the same as in the current Revoice Pro Session.
  3. Complete the Bounce operation.
  4. Drag bounced files into Revoice Pro.

 

Cubase (V5 and higher)

(Similar instructions for Nuendo and other DAWs might apply)

  1. In Cubase, Select Project menu and Project Setup.
  2. As shown in Cubase Project Setup window, make sure the Project Setup "Record File Type" is set to Broadcast Wave File as shown in image below left.
  3. In Cubase, select the audio region(s) to Bounce (can include across multiple tracks).
  4. Select Cubase Audio menu and choose Bounce Selection as shown below right.
  5. Complete bounce.
  6. Drag bounced files into Revoice Pro.

Cubase Project setupCubase Bounce selection

 

Back to Index

 

Logic File menuLogic Pro (V8 and higher)

To use Export or Bounce (to disk) functions in Logic Pro, select the Logic Pro FILE menu and then chose Export or Bounce at the bottom of menu as shown on the left below (for Logic Pro 8).

The user should be familiar with the various options and settings required.

For use in Revoice Pro, the we recommend outputting to .wav or Broadcast Wave File formats in mono or stereo PCM.

 

 

Logic Bounce MenuIn the Bounce menu (shown for Logic Pro 8 at the right) there are several options that must be set correctly, such as PCM in Destination and Wave in File Format. Resolution, Sample Rate and other settings are up to the user.

File Type: Split is useful for generating files that will go to separate Revoice Pro tracks.

 

Additional options such as Mode: Offline (instead of "Realtime") makes the generation of the audio files be done in significantly less than real time .

Back to Index