User Guide Index

Operating Revoice Pro with Nuendo and Cubase

 

Latest Information

For the most up-to-date information on use of Revoice Pro with Nuendo and Cubase click here.

Overview

Revoice Pro is a stand-alone program to give you the maximum processing power and flexibility in a multi-track environment. When you want to use it, you need to start it manually, like any other program.

Audio to be processed in Revoice Pro needs to be selected in Nuendo (Cubase), transferred to Revoice Pro, processed and then the processed audio is transferred back to Nuendo (Cubase).

There are very easy, familiar and fast ways to transfer audio between Revoice Pro and Nuendo (Cubase), mainly using "drag and drop" or copy and paste operations. To move multiple processed tracks (or portion of multiple tracks) from Revoice Pro back to Nuendo (Cubase) at the same time, the Export Audio command [CMD E (Mac)/Ctrl E (Windows)] can be used as described here.

What's more, the files transferred from Nuendo (Cubase) are not duplicated (saving storage space and housekeeping) and clip names are maintained in both directions.

Also, a VST3 Revoice Pro Monitoring plug-in is included with Revoice Pro that, once installed, allows you to hear audio playback from Revoice Pro through Nuendo's (Cubase's) audio outupts. It also lets Revoice Pro optionally lock to the Nuendo (Cubase) Playback with sample-accurate sync. This lets you check processed audio "in place" with Nuendo audio and video before you transfer it from Revoice Pro back to Nuendo (Cubase).

In this Chapter, we explain how to set up Revoice Pro's Session variables to match the Nuendo (Cubase) Project, and how to use the simple audio transfer methods and the monitoring plug-in.

NOTE: In the following instructions, the pictures shown are using Nuendo 6, but there are similar windows and controls in Nuendo 5 and up and Cubase 5 and up that will match these instructions.

Other information on the detailed use of Revoice Pro, is in the other Chapters of this User Manual (found in the Revoice Pro Help Menu) and in the many tutorial videos available.

 

Transfering audio from Nuendo (Cubase) to Revoice Pro

Setup Revoice Pro for audio transfers

Before doing any audio transfers, it is necessary to make sure that the Revoice Pro Session variables match those of the Nuendo (Cubase) Project. This is generally only done once per Session (but the settings can also be saved as a default).

  1. Open Nuendo and the required project.
  2. Set Nuendo's Tranport Panel Tempo to "FIXED" and note the Bar/Beats value as shown below.
    Set Nuendo Temp Fixed
  3. In Nuendo's Project menu, open Project Setup and note the Frame Rate and Start time as shown below.
    Nuendo Project Setup

  4. Revoice Pro Project Settings Open Revoice Pro and in the Windows menu select Settings to open the Project Settings Window shown right (for Windows OS). The four fields listed below must be set to match the Nuendo (Cubase) Project settings. The picture right shows the required settings for the example Nuendo Project shown above.

    • Set Timecode Rate to the Nuendo (Cubase) Project Frame Rate.
    • Set the DAW Timecode Offset to the Nuendo (Cubase) Project Start time.
      (Note: Revoice Pro does not support negative project Start times.)
    • Set the DAW setting to "Nuendo 5.5 & Later" ("Cubase 6 & Later" or other appropriate setting)
    • Set the DAW BPM value to Nuendos (Cubase) Tempo value.
    • Click OK when all settings have been made.

  5. If you wish to reuse these Project settings for futher Revoice Pro sessions, open the Revoice Pro File menu and select Save As Default Session.
Back to Index

 

Drag and Drop Transfers to Revoice Pro

The most efficient way to transfer audio from Nuendo (Cubase) to Revoice Pro is by using "Drag and Drop". But if there isn't room in one computer screen to see multiple program windows, you can also Copy the audio in Nuendo (Cubase) and Paste into a Revoice Pro track. These are both explained in detail below.

NOTES:

  1. In Nuendo (Cubase) select one or more audio clips in a single track that you want to transfer to Revoice Pro to process.

    IMPORTANT - We will show first transferring one Region from Nuendo to Revoice Pro and processing that. When transferring multiple regions from Nuendo to Revoice Pro, the regions will be transferred, but before processing, one extra action willl be required which will be explained below.

    You can use any of the Nuendo selection commands including CLICKing on a single region, or use SHIFT click to select multiple regions, or Shift+double click at the first event of the track to select all following events of the track.
    Nuendo - Select Guide

  2. Transfer the audio to Revoiced Pro: If you can see both the Nuendo and Revoice Pro windows, you can easily LEFT CLICK and Drag the selected region(s) from Nuendo to a Revoice Pro track and "drop" it by releasing the mouse button.
    Or, you can use the COPY command in Nuendo and then go to the Revoice Pro window, put the mouse over the destination track, RIGHT CLICK and select the Paste command shown below.

    RVP Paste audio

    Both of these approaches will deposit the audio at the correct timecode, as shown for the selected Guide audio below. (Normally, the first Guide audio is placed into Track 1.)

    RVP- Pasted Guide

    Important Notes:
  1. If using an APT process, select the audio clip(s) in the Nuendo Project that are to be aligned (only in one track) as shown below.

    Nuendo - select Dub

  2. Drag & Drop (or Copy and Paste) the clip(s) as described in (2) above, to the next Revoice Pro track as shown below.

    RVP - Pasted Dub

  3. If the length of the audio is shown selected (green) is roughly equally long for the whole Guide and Dub, you can now Process the audio in Revoice Pro as described in the User Manual chapters on APT processing.

    RVP Process WindowNormally, this means that with the Revoice Pro window selected, press the "B" key to bring up the New Process window (shown right).

  4. If the settings in that window are correct, then click New Process button (or press the keyboard N key) and Revoice Pro will use the APT's User Default settings to process and play the audio.

    See the chapters on APT and Doubler processing and auditioning for more details.

  5. If the processed audio sounds correct, it can be easily transferred back to Nuendo (Cubase) as described next.

IMPORTANT: If you have transferred more than one region for the Guide or Dub, you should click here to read what additional operations you might need to take.

Back to Index

 

Transfer processed audio from Revoice Pro to Nuendo (Cubase)

There are two main methods for transferring processed audio from Revoice Pro to Nuendo (Cubase). Which one you chose depends on whether you want to transfer a single clip or many clips from optionally many tracks at the same time.

A)  For transferring a single audio region from Revoice Pro to Nuendo (Cubase), drag and drop is simple and fast.

B)  For transferring many audio files to Nuendo (Cubase), use Revoice Pro's "Export Audio" command in the File menu.

We outline both methods below.

Note that you cannot copy and paste audio from Revoice Pro to Nuendo (Cubase).

 

Drag and Drop from Revoice Pro to Nuendo

  1. In Revoice Pro, locate the processed region to transfer, hold down SHIFT and Ctrl (Mac: SHIFT and ALT) keys on the keyboard.
    (Do not CLICK the mouse first or you might move the waveform or a feature).
  2. LEFT CLICK on the processed region while keeping the keys down. A document icon should appear as shown below.

    Revoice - Ready to drag audio

  3. Release the CtrlL + Shift Keys (Mac: Alt+Shift). This is necessary for correct operations.
  4. Now drag the Document icon to a the desired Track in Nuendo's Project window as shown below.

    Nuendo Drag in

  5. Release the mouse button and the waveform should appear (followiing an option window to move and modify the audio). The result should look similar to the example below.

    Note that the audio is not at the correct time.

    Nuendo - After Drag release
  6. In Nuendo, ensure the imported clip is still selected and select Nuendos "Move to > Origin" found in the Edit Menu (as shown below) or operate its corresponding key command.

    Nuendo - Move to origin

  7. The result of doing this operation is that the clip will now be at the correct time-code and aligned with the Guide audio, as shown below.

    Nuendo - After move to orign

  8. You can repeat the above capture, process and import steps along the timeline or from any other tracks.

    Back to Index


Export Audio from Revoice Pro to Nuendo.

In Revoice Pro, select "Export Audio..." from the File menu.
This will allow exporting one or more complete tracks or a specified range (using the Playback Range) all at once.

Full illustrated general details for this are provided here, but a brief overview of the steps required is provided below.

  1. You can provide a "base" name for the tracks as well for autonaming.
  2. Select / check all audio tracks to be exported and "Save" it to a dedicated location in the operating system's file directory.
  3. Select the exported and relevant audio files in the operating system and drag and drop them into the Nuendo (Cubase) project window to the desired track.
  4. A dialogue window in Nuendo (Cubase) will appear asking whether to insert the objects either to one or different tracks. Select "Different tracks".
  5. If all imported event are still selected in Nuendo, apply Nuendos (Cubase) "Move to > Origin" found in the Edit Menu or use its corresponding key command.
  6. Optionally, keep all events selected, and apply "Detect Silence" to be found in Audio menu > Advanced.
  7. Adjust the values to separate the file(s) back into the relevant lines/takes again.

The result will appear with the same structure of audio events/takes in the Nuendo project as before the aligning process.

 

Monitoring Revoice Pro audio through Nuendo (Cubase)

  1. In Nuendo (Cubase), open the Devices Menu and select VST Instruments

    Nuendo - Devices Menu

  2. The window below will open. LEFT CLICK on Track Instruments.

    Nuendo - VST3 Instruments
  3. A window similar to the one below will appear.

    Nuendo - Track Instrument menu
  4. If required, LEFT CLICK Add Track. Then LEFT CLICK on No VST Instrument and select Revoice Pro Monitor from the menu list that will be similar to the one below

    Nuendo - Select Revoice Pro Monitor
  5. The Revoice Pro Monitor will be displayed in a window
    Nuendo Revoice Pro Monitor

  6. In Revoice Pro check that the Monitor swich (shown in red box below) is enabled as shown.
    Revoice Pro Monitor on
  7. You should now be able to start playing audio from Revoice Pro through the Nuendo (Cubase) system and Revoice Pro will also follow Nuendo's playback.
  8. NOTE: In Nuendo (Cubase) make sure that the Release Driver when Application is in Background option is not checked. If this option is checked when you try and start playing from Revoice Pro the operaiton will fail because Nuendo (Cubase) is in the background.

    Nuendo - VST Audio Panel

  9. If you want to stop Revoice Pro from playing audio when you are playing audio in Nuendo (Cubase) you can click the Monitor switch to OFF. Alternatively you can mute the Nuendo (Cubase) track which has the Revoice Pro monitor plug-in, but this will not stop Revoice Pro from following the Nuendo timecode.
Back to Index

Processing multiple regions transferred from Nuendo (Cubase) to Revoice Pro

The user can easily select and transfer multiple regions of audio from a track in Nuendo (Cubase) to Revoice Pro 3 in a single transfer.

IMPORTANT:
However, after the transfer, when the audio is displayed in Revoice Pro 3, only the last of the transferred Regions will be the selected audio.

This means that if the user creates a New Process in Revoice Pro by pressing the New Process command that automatically uses "Selected audio" to set the process length, the range of the process will not automatically be set for the length of all the new transferred regions.

In this case, to process all the transferred regions, the user can easily set a Playback Range in Revoice Pro to include all the newly transferred audio (or a sub-range) just before pressing the New Process command. If this is done, then all the regions within the Playback Range will be included in the process.

This issue and procedure is shown below.

  1. In the image below, the Guide is continuous and the dub is in 3 sections.
    Nuendo - Input Dub Segmented
  2. After Copy and Paste (or Drag and Drop) are used to transfer the Guide audio to Revoice Pro (shown below in top track) and then the Dub audio (in 2nd Track), only the last region of the Dub (in green) will be selected in Revoice Pro.

    Nuendo - Revoice with Segmented Dub

  3. Revoice Segmented Dub-selected AudioTo create the APT process, the normal procedure is to press B key and bring up the New Process window as shown left.

    Note that under Initial Input Start and End, "Selected Audio" is shown. If used right away, then the APT Process range would be set only by the range of the audio shown selected in green. This would not match the length of the Guide.




  4. To get the right length of audio (when the selected Guide or Dub have been segmented) one of the easiest solutions is to simply enter a Playback Range (as shown in yellow at the top of the image below) the runs for the length of the signals that want to be processed (as described in further detail here).

    (Note - the Playback Range track can also be at the bottom of the Revoice Pro window - if that is the Preference set).
    Revoice Segmented Dub - use Playback Range
  5. Creating a Playback Range will automatically change the "Initial Input Start & End" control to show "Selected Playback Range as shown below.

    New Process Window with Playback Range

  6. The user now only needs to press the New Process button at the bottom of that window or the N key on the keyboard, and the New APT process control blocks and output space will be created as shown below.
    New Process created with Playback Range

  7. If the user is happy that the APT process controls are set correctly, then pressing the Space Bar on the keyboard will create the output in the designated track as shown below.

    New Process Edited Playback Range Pitch

  8. If any further manipulations are needed, these can be done as described in the APT chapters.
    New Process Edited Playback Range Pitch 2
  9. Finally, the processed audio can be dragged back to Nuendo (Cubase) to the track reserved for Revoice Pro's output and positioned at the correct timecode (as shown highligted below) as described here, .

Returned Audio with Playback Range

Back to Index